利用 Web 更改 Mac OS X Snow Leopard Server 使用者密碼

一直以為 Mac OS Server 無法利用網頁的方式更改使用者密碼(或者是說,必須利用 third party 的程式),其實應該是自己沒有 K 到書。

不過今天在搜尋的時候,有找到一篇文章 “Ten Good things about Snow Leopard for IT admins” 裡面有提到,Snow Leopard Server 有提供這個功能,所以不死心,再到處找找看。後來真的被我找到了。我真的是瞎了眼睛,之前都沒看到:

1. 在 Dock 上點選 “Server Admin”

Screen shot 2009-10-01 at 1.42.54 PM

2. 點選 “Web”服務,再點選”Sites”分頁

Screen shot 2009-10-01 at 1.43.23 PM3. 點選下面的 “Security” 分頁,把 SSL 啟動。

Screen shot 2009-10-01 at 1.43.43 PM

4. 點選 “Restart” 重新啟動 Web Service

Screen shot 2009-10-01 at 1.44.02 PM

5. 這個時候,應該會看到 Port 已經由 80 改為 443 了。接下來點下下面 “Web Services” 的分頁,最後再勾選 “Change their password” 來打開這個功能。

Screen shot 2009-10-01 at 1.44.24 PM6. 因為這個時候 Web Service 已經改成 SSL 服務了,因此只能使用 https 連線進來。如果還是需要 http 的服務,則必須再加上 port 80 的服務。這時,只需再加入一個服務即可。

Screen shot 2009-10-01 at 1.45.39 PM7. 設定完之後,可以試試看,先使用 http 連線進去,可以發現只有三樣服務。

Screen shot 2009-10-01 at 1.46.28 PM8. 如果使用 https 的方式進入,可以看到最右邊多了一個 “chang password” 的服務了。

Screen shot 2009-10-01 at 1.46.43 PM

9. 點選之後,會要求先使用舊密碼登入。

Screen shot 2009-10-01 at 1.46.51 PM

10. 進入之後,就可以更改密碼了。

Screen shot 2009-10-01 at 1.47.08 PM11. 輸入原密碼,再輸入新的密碼。修改完密碼之後,點選下面的 “Save” 就成功修改了!

Screen shot 2009-10-01 at 1.48.40 PM

修改 Mac OS 的快速鍵

因為現在用的鍵盤是 PC 的鍵盤,所以在切換輸入法的時候,快速鍵的對應很不習慣。所以就想改變一下快速鍵。

不知道是我理解能力太差還是怎麼了,在”鍵盤”這個視窗中,它說”如我要更改快速鍵,請按兩下快速鍵”。我就傻傻的照指示,在鍵盤上按下兩次快速鍵。結果,什麼事都沒做。

試了很久,才發現,原來是要使用”滑鼠”,在”快速鍵”那一欄點兩下,再修改。

螢幕快照 2009-09-29 9.19.09 AM

  1. 先在1號框的地方選擇要修改的分類,然後在右邊欄,選擇要修改的項目。
  2. 接下來,在2號框的地方使用滑鼠點兩下。
  3. 最後,使用鍵盤按下新的快速鍵組合,就完成了。

一台 Router 有幾個 OSPF Router ID ?


在設定 OSPF 的時候,Router ID 是 OSPF 用來識別 Router 用的。要成功的讓 OSPF 交換路由,必須先建立 neighbor relationship。要成功的建立 OSPF neighbor,每個 Router 必須要有唯一的 Router ID,是其中的一個條件。

我們來複習 OSPF Router ID (RID) 的選擇方式:

  1. OSPF process 會檢查是否有使用 router-id 這個指令手動設定 RID。
  2. 如果沒有手動設定 RID,OSPF process 會看是否有 active (up/up) 的 Loopback 介面。如果有,則挑選 Loopback interface 中最高的 IP address,將之設定為 RID。
  3. 如果 Router 中沒有 Loopback interface (或都被 shutdown),則會選擇 active (up/up) 的實體介面(Physical interfaces)中最高的 IP address,將之設定為 RID。
  4. 如果也都沒有 active 的實體介面,或 active 的實體介面都沒有設定 IP address,那麼 OSPF 將無法設定。(如下例)
Router#show ip int brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES manual administratively down down

FastEthernet0/1 unassigned YES manual administratively down down

Vlan1 unassigned YES manual administratively down down
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 100
OSPF process 100 cannot start. There must be at least one “up” IP interface
Router(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
Router#
show ip ospf
%OSPF: Router process 100 is not running, please configure a router-id
Router#

我們再來看這個例子:
2009-09-20_101306
R1:

interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 2.2.2.1 255.255.255.255
!
interface Loopback3
ip address 3.3.3.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
!

router ospf 100
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0


R2:

interface Loopback1
ip address 1.1.1.2 255.255.255.255
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
!

router ospf 100
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0

當 OSPF 成功建立起 neighbor 之後我們可以從 R2 看到,R1 的 RID 是 3.3.3.1,合乎上述的選擇方式。
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.1 1 FULL/BDR 00:00:30 10.1.1.1 FastEthernet0/0
R2#

但也因此,很多人都以為每一台 Router 都只有“一個”唯一的 Router ID。
如果,我想在 R2 上面看到 R1 的 RID 是 2.2.2.1,而且不能使用 router-id 指令,也不能將 Loopback 介面 shutdown,該怎麼做呢?
要解這個問題,必須先了解:在一台 Router 之中,可以啟動多個 OSPF process。而每一個 OSPF process 都會使用一個唯一的 Router ID。
所以上面這個問題,我只需要在 R1 上面先設定一個 OSPF process,讓它選定 3.3.3.1 為 RID,但不下任何 network 指令。再設定一個要與 R2 建 neighbor 的 OSPF process,讓它選定 2.2.2.1 為 RID。

R1:
R1#show run
router ospf 100
log-adjacency-changes
!
router ospf 200
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0

R1#show ip ospf
Routing Process “ospf 100” with ID 3.3.3.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 0. 0 normal 0 stub 0 nssa
External flood list length 0
Routing Process “ospf 200” with ID 2.2.2.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 2 times
Area ranges are
Number of LSA 4. Checksum Sum 0x01969f
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

R2:
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.1 1 FULL/BDR 00:00:35 10.1.1.1 FastEthernet0/0

更改 Blogger 的網站小圖示 (Favicon)


在 Google 的 Blogger 中,如何將每個視窗最上方的“網站小圖示” (Favicon) 改成自己專屬的呢?

  1. 首先,要製作出自己的專屬 Favicon。最方便的做法就是,先把要改的圖作好,然後到 Favicon Generator & Gallery 去,上載圖檔,然後由它自動產生出 .ico 的 Icon 檔案來。
  2. 接下來,再將產生的檔案放到網路連結得到的地方,例如網路相簿。先複製好這個 Icon 檔案的 URL,如:http://www.photo.com/images/favicon.ico
  3. 然後再登入你的 Blogger 的管理面板,選擇“版面配置”下的“修改HTML”
  4. 在“修改範本”的內容裡面,找到 “<title><data:blog.pageTitle/></title>”
  5. 在它的下一行插入 <link href=’FaviconURL’ rel=’shortcut icon’ type=’image/x-icon’/>。其中 FaviconURL 指的就是在第二步記錄下來的 URL。
  6. 最後,按“儲存範本”就可以了!
How to change Blogger's favicon
How to change Blogger's favicon

也可以先將範本備份到電腦中,在電腦中編輯完在上傳。這樣子就能夠留存以後備用。

2009 Family Video


小妹妹跳 Sorry Sorry 舞

芷翎新居入厝

台北動物園看大象